Sendmail で受信できても送信できない問題を何とかしました!!!

スポンサードリンク


アイエエエエエエエエエエエエエ、ナンデ、Sendmail ナンデ、ということが起こりました。設定ファイルは一切未修正です。Sendmail や、サーバの再起動もしていません。なのに Sendmail で突然メールが送信できなくなりました。受信のみできます。自分のサーバではなかったのですけれど、3時間ほど復旧にかかりましたのでメモします。

復旧まとめ

  • Sendmail を再起動したら直った。

復旧までの試行錯誤あれこれ

設定ファイルをいじったわけではないのでこれらは問題なはず、、、と思いつつ、まずは基本の設定ファイルを見直しました。その際、ドメイン設定も含めSendmailでメール送受信ができるようになるまで試行錯誤まとめ | oki2a24 を参考にしました。

Sendmail 設定ファイル系

  •  /etc/mail/sendmail.mc
  • /etc/mail/local-host-names
  • /etc/mail/access

ホストネーム系

  • hostname
  • /etc/hosts
  • /etc/sysconfig/network

問題なしでした。とはいえ、設定は一切いじっていないので、予想の範囲内です。では、ポートが閉じられていたり、するのでしょうか?メールのポート番号、25をチェックします。

ポート25番系

  • iptables -L -nv
  • netstat -nl

こちらも問題なしでした。パケットを受け入れています。では何でしょう?ゾーン情報というのを知ったので調べてみました。なお、下であげているコマンドは、自分のサーバに置き換えています。実際は別のサーバ、ネームサーバを指定しました。

ゾーン情報系

  • dig oki2a24.com
  • dig @01.dnsv.jp. oki2a24.com axfr

やはり問題なかったです。ちなみに、ゾーン情報について、参考になったサイトです。

ログを見ました。

エラーが起きたらまずログです。設定ファイルとか確認しちゃいましたけれどね。具体的には次の5ファイルです。ローテートの設定によっては、もっと多かったり、少なかったりします。全部ダウンロードして、調べました。

  • /var/log/maillog
  • /var/log/maillog.1
  • /var/log/maillog.2
  • /var/log/maillog.3
  • /var/log/maillog.4

で、怪しそうなところを発見しました。日付やメールアドレスなどはでたらめになります。

warning: cannot open /etc/hosts.allow: Too many open files in system
・・・
(may be forged) did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA-v4
・・・
Apr 11 10:18:27 server sendmail[19833]: q4L2cRIS019833: from=<from@from.jp>, size=2682, class="0", nrcpts=2, msgid=<201204110218.q4L2cRIS019833@server.jp>, proto=ESMTP, daemon=MTA-v4, relay=localhost.localdomain [127.0.0.1]
Apr 11 10:18:27 server sendmail[19851]: q4L2cRIS019833: to=<to1@to1.jp>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=152682, relay=to1.jp., dsn=5.1.2, stat=Host unknown (Name server: to1.jp.: host not found)
Apr 11 10:18:27 server sendmail[19851]: q4L2cRIS019833: to=<to2@to2.jp>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=152682, relay=mx5.mail.to2.jp., dsn=5.1.2, stat=Host unknown (Name server: mx5.mail.to2.jp.: host not found)
Apr 11 10:18:27 server sendmail[19851]: q4L2cRIS019833: q4L2cRIS019851: DSN: Host unknown (Name server: mx5.mail.to2.jp.: host not found)
Apr 11 10:18:27 server sendmail[19851]: q4L2cRIS019851: to=<to3@to3.jp>, delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=33918, relay=to3.jp., dsn=5.1.2, stat=Host unknown (Name server: to3.jp.: host not found)
Apr 11 10:18:27 server sendmail[19851]: q4L2cRIS019851: q4L2cRIT019851: return to sender: Host unknown (Name server: to3.jp.: host not found)
Apr 11 10:18:28 server sendmail[19851]: q4L2cRIT019851: to=haspr347, delay=00:00:01, xdelay=00:00:00, mailer=local, pri=34942, dsn=2.0.0, stat=Sent

強調した行が怪しいです。「dsn=5.1.2, stat=Host unknown」で検索してみたりしたのですけれど、わかりません。

わかりません。どうしたらいいでしょう?ここで、ふと、再起動したらどうだろう、と思いました。ま、まさかね、ハハッ。

再起動したら Sendmail での受信はもちろん、送信もできるようになりました。。。

ちなみに、無事送信できたときのログがこちらになります。「dsn=2.0.0, stat=Sent」。うん!いいログですね♪

Apr 22 17:21:50 server sendmail[7568]: q4M8Lo3f007568: from=from@server.jp, size=352, class="0", nrcpts=1, msgid=<201204220821.q4M8Lo3f007568@server.jp>, relay=root@localhost
Apr 22 17:21:50 server sendmail[7569]: q4M8LoQx007569: from=<from@server.jp>, size=526, class="0", nrcpts=1, msgid=<201204220821.q4M8Lo3f007568@server.jp>, proto=ESMTP, daemon=MTA-v4, relay=localhost.localdomain [127.0.0.1]
Apr 22 17:21:50 server sendmail[7568]: q4M8Lo3f007568: to=to@to.jp, ctladdr=from@server.jp (500/500), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30352, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (q4M8LoQx007569 Message accepted for delivery)
Apr 22 08:21:50 server dovecot: imap-login: Login: user=<from>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Apr 22 08:21:50 server dovecot: IMAP(from): Disconnected: Logged out bytes=35/525
Apr 22 08:21:50 server dovecot: imap-login: Login: user=<from>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
Apr 22 08:21:50 server dovecot: IMAP(from): Disconnected: Logged out bytes=1611/31623
Apr 22 17:21:52 server sendmail[7574]: STARTTLS=client, relay=to.jp., field=cn_issuer, status=failed to extract CN
Apr 22 17:21:52 server sendmail[7574]: STARTTLS=client, relay=to.jp., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Apr 22 17:21:53 server sendmail[7574]: q4M8LoQx007569: to=<to@to.jp>, ctladdr=<from@server.jp> (500/500), delay=00:00:03, xdelay=00:00:03, mailer=esmtp, pri=120526, relay=to.jp. [999.999.99.9], dsn=2.0.0, stat=Sent (q4M8LoQl022344 Message accepted for delivery)

おわりに

冒頭の「アイエエエ」はニンジャスレイヤーのつもりです。ワザマエ!

“Sendmail で受信できても送信できない問題を何とかしました!!!” への1件の返信

コメントを残す