【CentOS 6】pip install ply==3.4 すると yum での python-pip インストールが失敗する

スポンサードリンク

失敗した手順

  1. yum -y --enablerepo=peel install python-pip
  2. pip install ply==3.4
  3. yum -y --enablerepo=peel install python-ply
  4. 失敗

pip install ply で ply-3.9 をインストールした場合は、同様の問題は発生しませんでした。

失敗しない手順

  1. yum で python-ply をインストール
  2. pip で ply 3.4 をインストール

おわりに

他にもさまさまなパッケージを導入しようと試行錯誤しておりました。そんな状況でしたから気がつきませんでしたけれども、pip か yum のどちらかのインストールだけで良く、両方でインストールする必要はないのかしら。

そうであるならば、pip ですとバージョン指定ができますから、こちらを使用してインストールした方が融通が利きそうですわね。

以上です。


スポンサードリンク

コメントを残す