【Android Studio】Error:A problem occurred configuring project ‘:app’. エラーは Gradle の buildToolsVersion を修正で解決!

スポンサードリンク

遭遇したエラー

resolve-errora-problem-occurred-configuring-project-app1.png

Error:A problem occurred configuring project ':app'.
> failed to find Build Tools revision 22.0.0

結果、ビルドが完了せず、アプリも起動できませんでした><。

ビルドエラーの原因

  • SDK Manager で何でもかんでもインストール、アップデートしたからかしら?

おそらく上記が原因で間違いありませんの♪

だって、SDK Manager を覗いてみますと Android SDK Build-tools 22.0.0 がございませんもの。代わりに、Android SDK Build-tools 22.0.1 はございましたけれども。

resolve-errora-problem-occurred-configuring-project-app2.png

アップデートでマイナーバージョンアップされたのですわ♪

対処方法

Gradle ファイル(app ディレクトリ内)の buildToolsVersion を修正してあげれば良いですわ♪

  1. AndroidStudioProjects/ProjectName/app/build.gradle
  2. buildToolsVersion “22.0.0”

    buildToolsVersion “22.0.1”

以上ですの!

Run ‘app’ などでビルドを動かしましたら、無事にアプリの起動までできました♪

おわりに

久しぶりに起動したプロジェクトでアプリを立ち上げた途端にエラーとなりましたので、ちょっと焦ってしまいました><。

そういえば直前に SDK Manager を更新したのですわ。

ビルドツールはメジャーバージョンは別の SDK と認識されております。

けれども、マイナーバージョンのアップデートの場合は別の SDK として認識されないため、ビルドエラーとなりましたの。

なお、Android Studio のバージョンは 1.1.0 でございます。

以上です。


スポンサードリンク

コメントを残す