yum update で WordPress へのアクセスできない! /etc/httpd/conf.d/proxy_ajp.conf 除外で解決♪

スポンサードリンク

ポイント

  • yum –enablerepo=epel,remi,rpmforge update で /etc/httpd/conf.d/proxy_ajp.conf が作られた。
  • このファイルで指定しいるLoadModule proxy_ajp_module modules/mod_proxy_ajp.so が実行できない、つまりモジュールが読み込めないためエラーとなった。
  • /etc/httpd/conf.d/proxy_ajp.conf をリネームして設定にとして読み込まれないようにし、httpd を起動できるようにして解決した

WordPress にアクセスできなくなってから解決するまでの道のり!

yum update を実行ですの!問題発生ですの><

サーバーのソフトはセキュリティ上、そしてパフォーマンス上、できるだけ最新にしたいと考えております。ですので、機会がある度にアップデートがないか、確認しております。

yum --enablerepo=epel,remi,rpmforge update

httpd、mysql、php などのアップデートがあるようでした。

Dependencies Resolved

===============================================================================================
 Package                 Arch          Version                          Repository        Size
===============================================================================================
Updating:
 httpd                   i386          2.2.3-85.el5.centos              updates          1.2 M
 httpd-devel             i386          2.2.3-85.el5.centos              updates          155 k
 mod_ssl                 i386          1:2.2.3-85.el5.centos            updates           97 k
 mysql                   i386          5.5.37-1.el5.remi                remi             7.6 M
 mysql-libs              i386          5.5.37-1.el5.remi                remi             1.1 M
 mysql-server            i386          5.5.37-1.el5.remi                remi              13 M
 net-snmp                i386          1:5.3.2.2-22.el5_10.1            updates          705 k
 net-snmp-libs           i386          1:5.3.2.2-22.el5_10.1            updates          1.3 M
 net-snmp-utils          i386          1:5.3.2.2-22.el5_10.1            updates          193 k
 php                     i386          5.4.27-1.el5.remi                remi             3.0 M
 php-cli                 i386          5.4.27-1.el5.remi                remi             3.0 M
 php-common              i386          5.4.27-1.el5.remi                remi             1.1 M
 php-devel               i386          5.4.27-1.el5.remi                remi             3.0 M
 php-gd                  i386          5.4.27-1.el5.remi                remi             218 k
 php-imap                i386          5.4.27-1.el5.remi                remi              95 k
 php-mbstring            i386          5.4.27-1.el5.remi                remi             1.2 M
 php-mcrypt              i386          5.4.27-1.el5.remi                remi              57 k
 php-mysql               i386          5.4.27-1.el5.remi                remi             173 k
 php-pdo                 i386          5.4.27-1.el5.remi                remi             128 k
 php-process             i386          5.4.27-1.el5.remi                remi              68 k
 php-xml                 i386          5.4.27-1.el5.remi                remi             223 k
 tzdata                  i386          2014b-1.el5                      updates          774 k

Transaction Summary
===============================================================================================
Install       0 Package(s)
Upgrade      22 Package(s)

Total download size: 38 M
Is this ok [y/N]:

「y」で実行ですの。慣れきった操作ですわ。

しかし!完了後ブログにアクセスしてみようとしますとできません!あらら><。どどど、どうしましょう〜><。

クールになれ。海の男はタフだ。

yum update によるアップデートの進捗経過を確認してみます。

Running Transaction
  Updating       : tzdata                                                                 1/44 

WARNING : These php-* RPM are not official Fedora / Red Hat build and
overrides the official ones. Don't file bugs on Fedora Project nor Red Hat.

Use dedicated forums http://forums.famillecollet.com/

  Updating       : php-common                                                             2/44 
  Updating       : net-snmp-libs                                                          3/44 
  Updating       : httpd                                                                  4/44 
  Updating       : php-cli                                                                5/44 
  Updating       : net-snmp                                                               6/44 
  Updating       : php-pdo                                                                7/44 
  Updating       : net-snmp-utils                                                         8/44 
  Updating       : php-devel                                                              9/44 
  Updating       : php                                                                   10/44 
  Updating       : mod_ssl                                                               11/44 
  Updating       : php-gd                                                                12/44 
  Updating       : php-mbstring                                                          13/44 
  Updating       : php-process                                                           14/44 
  Updating       : php-xml                                                               15/44 
  Updating       : php-imap                                                              16/44 
  Updating       : php-mcrypt                                                            17/44 
  Updating       : httpd-devel                                                           18/44 

WARNING : This MySQL RPM is not an official Fedora / Red Hat build and it
overrides the official one. Don't file bugs on Fedora Project nor Red Hat.
Use dedicated forums http://forums.famillecollet.com/

  Updating       : mysql-libs                                                            19/44 
  Updating       : mysql                                                                 20/44 
  Updating       : php-mysql                                                             21/44 
  Updating       : mysql-server                                                          22/44 
  Cleanup        : php-mysql                                                             23/44 
  Cleanup        : mysql-libs                                                            24/44 
  Cleanup        : httpd-devel                                                           25/44 
  Cleanup        : php-devel                                                             26/44 
  Cleanup        : httpd                                                                 27/44 
  Cleanup        : php-gd                                                                28/44 
  Cleanup        : php-common                                                            29/44 
  Cleanup        : mysql                                                                 30/44 
  Cleanup        : php-mbstring                                                          31/44 
  Cleanup        : php-cli                                                               32/44 
  Cleanup        : net-snmp-utils                                                        33/44 
  Cleanup        : tzdata                                                                34/44 
  Cleanup        : mod_ssl                                                               35/44 
  Cleanup        : mysql-server                                                          36/44 
  Cleanup        : php                                                                   37/44 
  Cleanup        : net-snmp-libs                                                         38/44 
  Cleanup        : php-pdo                                                               39/44 
  Cleanup        : net-snmp                                                              40/44 
  Cleanup        : php-process                                                           41/44 
  Cleanup        : php-xml                                                               42/44 
  Cleanup        : php-imap                                                              43/44 
  Cleanup        : php-mcrypt                                                            44/44

なるほど、php モジュールと、MySQL のアップデートに警告が出ておりますわね。

怪しい!

原因は、PHP?、MySQL?それとも、、、

ということは、PHP もしくは MySQL のどちらかが原因でブラウザから WordPress へアクセスできないと言えそうです。

起動状態を確認してみますと、Apache が起動しておりません!きっとこれが原因ですわね♪

[root@oki2a24 ~]# /etc/init.d/httpd start
httpd を起動中: httpd: Syntax error on line 210 of /etc/httpd/conf/httpd.conf: Syntax error on line 2 of /etc/httpd/conf.d/proxy_ajp.conf: Cannot load /etc/httpd/modules/mod_proxy_ajp.so into server: /etc/httpd/modules/mod_proxy_ajp.so: undefined symbol: proxy_module
                                                           [失敗]
[root@oki2a24 ~]#

ここまでエラー原因が具体的になってきますと、大分落ち着き冷静になることができましたわ♪問題となっているファイル、行数が表示されておりますの♪

原因は、Apache でしたのね!

Apache の設定を変更して解決!

次の2点を確認すればよいですの!

  • /etc/httpd/conf/httpd.conf の 210 行目
  • /etc/httpd/conf.d/proxy_ajp.conf の 2 行目

/etc/httpd/conf/httpd.conf の 210 行目については、/etc/httpd/conf.d/ の設定ファイルも読み込むよ!と書かれておりましたので、これはこのままです。

/etc/httpd/conf.d/proxy_ajp.conf を見ます。

LoadModule proxy_ajp_module modules/mod_proxy_ajp.so

#
# When loaded, the mod_proxy_ajp module adds support for
# proxying to an AJP/1.3 backend server (such as Tomcat).
# To proxy to an AJP backend, use the "ajp://" URI scheme;
# Tomcat is configured to listen on port 8009 for AJP requests
# by default.
#

# 
# Uncomment the following lines to serve the ROOT webapp
# under the /tomcat/ location, and the jsp-examples webapp
# under the /examples/ location.
#
#ProxyPass /tomcat/ ajp://localhost:8009/
#ProxyPass /examples/ ajp://localhost:8009/jsp-examples/

LoadModule で modules/mod_proxy_ajp.so にある proxy_ajp_module を読み込もうとしておりますけれども、存在しませんのでエラーとなっている、ということのようですわね。

そもそも、proxy_ajp_module は必要なのかしら?設定ファイルの説明を読みますと、Tomcat のようなバックエンドサーバのサポートを追加できるようになる、とありますの。

わたくしたちは Apache と MySQL のみで Tomcat は使用しておりませんわ。ですから、proxy_ajp_module は不要ですの。

したがって、次のように設定ファイルをリネームして読み込まれないようにいたします。

mv /etc/httpd/conf.d/proxy_ajp.conf /etc/httpd/conf.d/proxy_ajp.conf.140405

そして、Apache を起動いたします。

[root@oki2a24 ~]# /etc/init.d/httpd start
httpd を起動中:                                            [  OK  ]
[root@oki2a24 ~]#

これでウェブブラウザから無事、わたくしたちのサイトへ再びアクセスできるようになりました♪

問題発生から 10 分程度で解決できて、良かったですの♪

おわりに

/etc/httpd/conf.d/ をあらためて調べてみますと、今回リネームしたファイルの他にこのようなものがございました。

  • proxy_ajp.conf.131208

これは、以前も同じ処理をしたことを意味しております。調べてみますと、まあ、ございましたわ!

ここで mod_proxy、mod_proxy_balancer、mod_proxy_connect、mod_proxy_ftp、mod_proxy_http を無効にしていたため、httpd のアップデートで問題発生した、と結論づけられます。

メモリ節約のために無効にしましたけれども、有効に戻そうかしら?悩みますの?

ですけれども、今回で対処はメモすることができましたから、しばらくこのままにいたしましょう。

以上です。


スポンサードリンク

コメントを残す